Minimum Required PHP Version

Download Monitor version 4.3 and higher require the server that is hosting your WordPress website to run at least PHP version 5.3 (but higher is always better).

If you install or update to Download Monitor version 4.3 or higher, Download Monitor will what “gracefully fail”. This means our plugin will not work but we won’t crash your website either. Because by default, running newer PHP code on older versions will crash your website.

I got a notice in my WordPress admin saying my PHP version is too low

If you install or update to Download Monitor version 4.3 or higher and your PHP version is lower than version 5.3, Download Monitor won’t work (it will not load at all). In order to fix this, there are two things you can do.

1. Upgrade your PHP version This is the best solution, by far. Most of the times this is something your host can do for you. This shouldn’t take long and they shouldn’t charge you for it. Send them an email them to upgrade the PHP version of your account. We recommend upgrading to PHP version 7.0 at least but in case of PHP version, the higher the better. After your PHP version is upgraded, Download Monitor will automatically work and the notice will go away.

2. Downgrade your Download Monitor version This really isn’t a great solution because not only will you continue to run on an old and insecure PHP version, you will also exclude yourself from any future plugin updates. These updates are important because they give you new features, bug fixes, and potential security vulnerability patches. The last Download Monitor version still working with PHP version 5.2 can be downloaded by clicking here.

Thank you for your feedback!

Was this article helpful? Yes · No